> < ^ Date: Tue, 07 Jul 1998 16:32:19 +0200 (MET DST)
> ^ From: Philippe Cara <pcara@vub.ac.be >
< ^ Subject: Re: loading GRAPE in MS-DOS

Dear Drew, dear GAP-Forum,

The problem you mention is (maybe) a bug in versions 3.4.3 and 3.4.4 of
GAP under DOS.

The variable PKGNAME which contains a list of possible paths to the
directory with the shared packages is not set correctly (in fact it is
empty or contains only one (wrong) path, I think). You should add the
correct path for your system, maybe with a command similar to:

Add(PKGNAME, "c:\\gap3r4p4\\pkg");

Note that the backslashes have to be typed twice.
After this RequirePackage should work fine.

Best regards,

Philippe Cara
Dept. of Math.
Vrije Universiteit Brussel
Pleinlaan 2
B-1050 Brussel
> Thank you for your quick reply.
> The specific problem plays out as follows (in 3.4.4):
> gap> RequirePackage("grape");
> Error, share library "grape" is not installed in
> LoadPackage( name ) called from
> RequirePackage( "grape" ) called from
> main loop
> While I'm in the process of installing Gap on my Linux partition, I would
> still like to know what the problem is here in DOS...
> Thanks

> < [top]