> < ^ Date: Tue, 29 Sep 1992 23:46:49 +0100
> < ^ From: Geoffrey Mess <geoff@math.ucla.edu >
> ^ Subject: patch on NeXT

Using patch-2.0.12u3, I tried to do the first upgrade. I got the
following results:

argo.math.ucla.edu> patch -p0 < upg3r1p1.dif
Hmm... Looks like a unified diff to me...
The text leading up to this was:

[... about 200 lines of text ...]

|Now for the upgrade itself
|diff -u doc/aboutgap.tex doc/aboutgap.tex
|--- doc/aboutgap.tex   Thu Apr  9 14:06:31 1992
|+++ doc/aboutgap.tex   Thu Apr 30 14:38:06 1992
File to patch: ^C
[ I exited with control C ]
I tried again using -pO instead of -p0 (literal rather than numeral)
and got the same result. This doesn't agree with the statement in the
upgrade that

Versions of 'patch' before (patchlevel 12u4) don't
| understand the unified 'diff' format of this upgrade file. In
this case
| you will see the following message.
| Hmm... I can't seem to find a patch in there anywhere.

I tried to install patch-2.0.12u4 (obtained from samson), but the
Configure process exited unsuccessfully. Has anyone succeeded either
in installing patch-2.0.12u4 on a Next or in doing the upgrade with
patch-2.0.12u3 ?

Geoffrey Mess

> < [top]