Goto Chapter: Top 1 2 3 4 5 6 Bib Ind
 [Top of Book]  [Contents]   [Previous Chapter]   [Next Chapter] 

6 Remarks on technical problems and the implementation
 6.1 Making the HeLP-package run
 6.2 How much 4ti2 and normaliz is really there?

6 Remarks on technical problems and the implementation

6.1 Making the HeLP-package run

For all basic functionalities of the HeLP-package (using only the solver normaliz) the standard GAP-installation should suffice to make everything work: Get the most recent GAP from the GAP-webpage by following the instructions on the Download-page. Make sure to also run InstPackages.sh as explained there. This should install all packages needed to run HeLP. Just start GAP and type LoadPackage("HeLP");. In GAP 4.8.2 the NormalizInterface has to be updated to version 0.9.6 or newer which can be obtained from the website of the package. For GAP 4.8.3 or newer this should not be necessary anymore.

Here is a checklist what to do, if the package does not work or you also want to use the solver 4ti2:

6.2 How much 4ti2 and normaliz is really there?

The reason, why the programs 4ti2 and normaliz are used in this package, is basically that they can solve systems of linear inequalities efficiently and there exist good GAP-Interfaces for them. However there is only one line of code where a function is called which accesses 4ti2 and a few more for normaliz. Thus the effort of using another solver of inequalities would be not so big, if there is a GAP-Interface for it. If you are aware of such a solver and would like to use it in this package, please contact the authors of this package. We will be happy to help.

 [Top of Book]  [Contents]   [Previous Chapter]   [Next Chapter] 
Goto Chapter: Top 1 2 3 4 5 6 Bib Ind

generated by GAPDoc2HTML