> < ^ Date: Mon, 07 Feb 2000 20:11:54 -0000
> ^ From: J.A. Ryan <jar@sdnp.org.mw >
> ^ Subject: GoppaCode command

Dear Gap

I am a newcommer to GAP and am interested in the GUAVA
package as I am doing some research in Coding Theory. However
I have had big problems in getting the command 'GoppaCode' to
work. I have followed the GAP manual very closely and given the
following commands:


Then I get the following error message----

'Error, no method found. For debugging hints type ..............
Error no first choice method found for 'CoefficientsRing' on 1
argument at Error(no_method_found)
CoefficientsRing(DefaultRing(p)) called from Codeword(x^(i-1) mod
temp, m+1) called from
VerticaConversionFieldMat(M,DefaultField(Flat(M))) called from
List([L,function(j), return j^i/value(GP(j);end);end)) called from
<<functions><arguments> called from read-eval-loop

Entering break read-eval-print loop ....

I have also tried other ways of defining L and G but to no avail. I
have also tried the AlternantCode command but again the same
error message. 

Can anyone help and get me started.

Would be most grateful.


> < [top]